h1

Excel Kassabuch

Mai 30, 2011

Die hier beschriebene Excel Arbeitsmappe Kassabuch zeigt die Anwendung einiger Excel Funktionen.

image

Der aktuelle Saldo des jeweiligen Monats wird jeweils berechnet indem der zum Anfangssaldo des Monats alle Eingänge addiert und alle Ausgänge subtrahiert werden:

=F2+SUMME(D6:D1000)-SUMME(E6:E1000)

In der Spalte Saldo wird der Saldo nur berechnet, wenn nicht auf der Zeile ein Betrag in der Spalte Eingang oder Ausgang oder in beiden steht. Wichtig ist hier der Einsatz der absoluten Bezüge, damit jeweils alle Ein-/Ausgänge von der ersten bis zur aktuellen Zeile berücksichtigt werden.

=WENN(UND(ISTLEER(D6);ISTLEER(E6));"";$F$2+SUMME($D$6:D6)-
    SUMME($E$6:E6))

Der Anfangssaldo im Januar wird in der Zelle F2 eingegeben. Der Anfangs-saldo jedes weiteren Monats entspricht jeweils dem Saldo des Vormonats. Z.B. wird der Anfangssaldo vom Monat Februar mit folgender Formel über-nommen:

=Januar!F3

Um in der Zelle C3 nicht den Namen des Monats manuell eingeben zu müssen, wird der Name des Blattregisters mithilfe einiger verschachtelter Funktionen übernommen:

=TEIL(ZELLE("dateiname";$A$1);FINDEN("]";ZELLE("dateiname";$A$1))+1;
    LÄNGE(ZELLE("dateiname";$A$1))-FINDEN("]";ZELLE("dateiname";$A$1)))

Die Funktion ZELLE(“dateiname”;$A$1) liefert den Blattnamen inklusive dem gesamten Dateipfad.

Die Funktion LÄNGE(ZELLE(“dateiname”;$A$1) liefert die Länge der gesamten Zeichenkette.

Mit der Funktion FINDEN("]";ZELLE("dateiname";$A$1)) wird die Position der schliessenden eckigen Klammer (“]”) gefunden. An der nächsten Zeichenposition der Zeichenkette beginnt der Blattname.

Die Funktion Teil(Text; Erstes_Zeichen; Anzahl_Zeichen) extrahiert aus der Zeichenkette den Namen des Blattes.

Die Arbeitsmappe kann hier für weitere Versuche heruntergeladen werden:

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s

%d Bloggern gefällt das: